Midnight Commander

Aplicaciones del sistema
2 mensajes Página 1 de 1
antoine
Miembro
Mensajes: 33
Registrado: Lun Mar 16, 2009 20:55
por antoine » Mar Oct 27, 2009 00:05
Con JWM instalado necesitaba de mc con urgencia... pero falló el .configure

La razón es que Debian Sid actualizada (a 26/10/2009) lleva automake-1.11 mientras que las fuentes de mc esperan la versión 1.10.

El asunto está, al parecer en modificar un enlace directo, a saber:

~/mc-4.6.2/config/install-sh

para que apunte a /usr/share/automake-1.11/install-sh en vez de a /usr/share/automake-1.10/install-sh.

Yo lo he instalado en modo kamikaze y por eso no indico exactamente como; así tendre mañana la oportunidad de comprobar la bondad de los scripts de desinstalación ;-)

Tengo que revisarlo todo pero hoy ya es un poco tarde.

Nota: tal vez convenga avisar de esta dependencia en el manual.

Gracias una vez más.
manualinux
Administrador
Mensajes: 613
Registrado: Sab Mar 03, 2007 00:43
por manualinux » Mar Oct 27, 2009 00:59
El asunto está, al parecer en modificar un enlace directo, a saber:

~/mc-4.6.2/config/install-sh

O hacer esto:
Código: Seleccionar todo
$ ./autogen.sh --disable-dependency-tracking --prefix=/usr

Que viene a ser lo mismo que esto, pero sin la ejecución automática del script configure
Código: Seleccionar todo
$ autoreconf -vif

Nota: tal vez convenga avisar de esta dependencia en el manual.

Esa función de aviso la cumple el foro, y este mensaje en concreto Blue_Light_PDT_01_19

Un cordial saludo.
2 mensajes Página 1 de 1

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado