Compilar e instalar Xfce : )

Menos KDE y GNOME, todos los demás
10 mensajes Página 1 de 1
aprendiz12
Miembro
Mensajes: 7
Registrado: Sab Sep 14, 2013 01:01
por aprendiz12 » Sab Sep 14, 2013 01:16
Hola, he seguido el manual de como compilar e instalar XFCE en linux, instalé todas las herramientas y librerias necesarias, apliqué las configuraciones de las variables del sistema global, con el script variables.sh, etc, hasta ahi todo correcto, pero me encontré con un error de configuración cuando llego a libxfce4util-4.10.0, el error que me da la terminal es:
checking for libxfce4util-1.0 >= 4.9.0... found, but 4.8.2
*** The required package libxfce4util-1.0 was found on your system,
*** but the installed version (4.8.2) is too old.
*** Please upgrade libxfce4util-1.0 to atleast version 4.9.0, or adjust
*** the PKG_CONFIG_PATH environment variable if you installed
*** the new version of the package in a nonstandard prefix so
*** pkg-config is able to find it.
supuestamente y si no me equivoco, esa libreria deberia haberse instalado con xfce4-dev-tools-4.10.0, que en el manual es el paso número 2 a la hora de instalar el escritorio.

Investigando un poco encontré en el foro de xfce a una persona con el mismo problema ...
http://forum.xfce.org/viewtopic.php?id=7948
Y al final dice que ha podido solucionarlo, solo que no cuenta como lo logró.
Intente buscar en otro foro pero nada, y la verdad me gustaria saber como poder resolver ese problemilla. Cualquier ayuda será grandemente apreciada. Gracias.
( Uso Lubuntu 12.04 )
manualinux
Administrador
Mensajes: 613
Registrado: Sab Mar 03, 2007 00:43
por manualinux » Sab Sep 14, 2013 14:04
Hola y bienvenido al foro y a la web Blue_Light_PDT_01_19

Hola, he seguido el manual de como compilar e instalar XFCE en linux, instalé todas las herramientas y librerias necesarias, apliqué las configuraciones de las variables del sistema global, con el script variables.sh, etc, hasta ahi todo correcto, pero me encontré con un error de configuración cuando llego a libxfce4util-4.10.0, el error que me da la terminal es:

El directorio /etc/profile.d no es funcional en todas las distribuciones basadas en Debian, cuando instales el script, comprueba abriendo una ventana de terminal que la variable PKG_CONFIG_PATH ha sido establecida, incluyendo el directorio /opt/xfce4/lib/pkgconfig en la lista de directorios que se mostrarán separados por dos puntos, con el siguiente comando:

Código: Seleccionar todo
$ echo $PKG_CONFIG_PATH

Si no es así, tendrás que añadir las variables de entorno al archivo .bashrc de tu home, que es la opción primera que siempre debe de utilizar el usuario. Las variables globales son siempre opcionales.

pero me encontré con un error de configuración cuando llego a libxfce4util-4.10.0, el error que me da la terminal es:
checking for libxfce4util-1.0 >= 4.9.0... found, but 4.8.2
*** The required package libxfce4util-1.0 was found on your system,
*** but the installed version (4.8.2) is too old.
*** Please upgrade libxfce4util-1.0 to atleast version 4.9.0, or adjust
*** the PKG_CONFIG_PATH environment variable if you installed
*** the new version of the package in a nonstandard prefix so
*** pkg-config is able to find it.
supuestamente y si no me equivoco, esa libreria deberia haberse instalado con xfce4-dev-tools-4.10.0, que en el manual es el paso número 2 a la hora de instalar el escritorio.

¿Has instalado el paquete libxfce4util-4.10.0.tar.bz2, que es el número 3 en el orden de compilación? ¿Tienes paquetes devel de xfce4 de una versión anterior instalados en tu sistema?
supuestamente y si no me equivoco, esa libreria deberia haberse instalado con xfce4-dev-tools-4.10.0, que en el manual es el paso número 2 a la hora de instalar el escritorio.

El paquete xfce-4-dev-tools no instala ninguna librería, es un paquete de herramientas y macros requerido para poder compilar xfce4.
aprendiz12
Miembro
Mensajes: 7
Registrado: Sab Sep 14, 2013 01:01
por aprendiz12 » Sab Sep 14, 2013 23:38
Blue_Light_PDT_01_16 ups me olvide que habia reemplazado el notificador de mansajes de lubuntu que viene por defecto por el de xfce 4.8 que es la version del repositorio en synaptic, eso instalo algunos dev de xfce 4.8, seguramente resultando en esa serie de problemas que tenia a la hora de compilar, otra cosa que no hice fue añadir las variables del sistema al archivo .bashrc de mi home, solamente utilize el script sh de variables. Pensaba que con las variables globales no hacia falta meter esas opciones al bashrc del home. Despues noté que no se puede descargar la terminal de xfce, no esta el la lista http://archive.xfce.org/xfce/4.10/src/, asi que ese paso fue omitido. Pero todo fue bién, y ahora ya puedo disfrutar de este entorno gráfico, Gracias por el manual y por la pronta respuesta. Estoy mas que contento con esta pagina y con tu trabajo!
manualinux
Administrador
Mensajes: 613
Registrado: Sab Mar 03, 2007 00:43
por manualinux » Dom Sep 15, 2013 18:42
Pensaba que con las variables globales no hacia falta meter esas opciones al bashrc del home.

No hace falta, siempre y cuando funcionen las globales.
Despues noté que no se puede descargar la terminal de xfce, no esta el la lista http://archive.xfce.org/xfce/4.10/src/, asi que ese paso fue omitido.

Cierto, lo han borrado. Pero que lo borren no significa que deje de existir. He subido el paquete al repositorio de software que tengo en SourceForge, y he actualizado el enlace de descarga del manual. Aún así, te pongo el enlace directo para que te lo puedas descargar desde este hilo. Gracias por la información y me alegra que te haya salido todo bien. Un saludo. Blue_Light_PDT_01_19

Enlace borrado por obsoleto
Jristz
Miembro
Mensajes: 6
Registrado: Jue Ago 15, 2013 15:22
por Jristz » Vie Nov 15, 2013 02:44
Pues Terminal fue renombrada a xfce4-terminal por ser el anterior nombre muy genérico.
http://archive.xfce.org/src/apps/xfce4- ... .2.tar.bz2 <- sigue ahí

En todo caso ahora han salido las versiones 4.11.x de algunos componentes, tal vez se puediese actualizar?
porque parole .5.90 depende de libxfce4ui-4.11 y gtk3-3.2.
manualinux
Administrador
Mensajes: 613
Registrado: Sab Mar 03, 2007 00:43
por manualinux » Vie Nov 15, 2013 14:28
Jristz escribió:Pues Terminal fue renombrada a xfce4-terminal por ser el anterior nombre muy genérico.
http://archive.xfce.org/src/apps/xfce4- ... .2.tar.bz2 <- sigue ahí
En todo caso ahora han salido las versiones 4.11.x de algunos componentes, tal vez se puediese actualizar?
porque parole .5.90 depende de libxfce4ui-4.11 y gtk3-3.2.

Las versiones impares en XFce 4 son versiones de desarrollo y no se pueden mezclar con las estables. Y sí, el paquete al que hace referencia el manual sigue ahí. El manual será proximamente actualizado a la versión 4.10.2, que es la actual estable. Aunque no entiendo por qué la llaman versión 4.10.2, cuando el único paquete que hace referencia a la misma es xfdesktop. El resto sigue igual, excepto algunos que han sido actualizados a la versión 4.10.1.

http://archive.xfce.org/src/apps/xfce4- ... .8.tar.bz2
manualinux
Administrador
Mensajes: 613
Registrado: Sab Mar 03, 2007 00:43
por manualinux » Vie Nov 15, 2013 18:49
El manual ya ha sido actualizado y gracias a Jristz por la información proporcionada.
Jristz
Miembro
Mensajes: 6
Registrado: Jue Ago 15, 2013 15:22
por Jristz » Mié Nov 20, 2013 07:52
De hecho según los desarolladores es solo Xfce 4.10, y dentro del desarollo de esta cualquier componente puede tomar cualquier versión (como xfce-terminal 0.6.1 o thunar 1.6.3) y seguir siendo estable.
actualmente son concideradas inestables cualquier versión que utilice la version none (por ahora 4.11) así que parole 0.5.3 es estable, pero 0.5.90 no
Como dijeron los de Xfce, a falta de mano de obra se nos ocurrió lo de las versiones.

Así que el nombre más correcto sería Xfce4 4.10-2 y no 4.10.2

xfce4-wmdock-plugin última versión estable -> http://git.xfce.org/panel-plugins/xfce4 ... .0.tar.bz2
La Traducción oficial: parche oficial de traducción al español

Te salida el cordinador de traduccion de Xfce al español
manualinux
Administrador
Mensajes: 613
Registrado: Sab Mar 03, 2007 00:43
por manualinux » Mié Nov 20, 2013 16:31
De hecho según los desarolladores es solo Xfce 4.10, y dentro del desarollo de esta cualquier componente puede tomar cualquier versión (como xfce-terminal 0.6.1 o thunar 1.6.3) y seguir siendo estable.

No es lo mismo 4.10 que 4.10.1, y en este aspecto deberían de mejorar la información que proporcionan de las revisiones del entorno en la página principal del mismo, porque todas las distribuciones y páginas de información sobre linux sí utilizan ese número de versión para hacer referencia a los cambios introducidos en Xfce4. Por cierto, Thunar 1.6.x daba problemas de ejecución con XFce 4.8.x, lo tuve que quitar del manual en su día y volver a la versión anterior. No siempre se cumple lo de la estabilidad supuesta.

http://linux.softpedia.com/get/Desktop- ... 2024.shtml

xfce4-wmdock-plugin última versión estable -> http://git.xfce.org/panel-plugins/xfce4 ... .0.tar.bz2

Es la misma que viene incluida en el manual con ruta de enlace diferente, y respecto a la traducción, ya sabes la política de este sitio web respecto a las traducciones, siempre alternativas, nunca oficiales. Por algo es esto una web personal.
Jristz
Miembro
Mensajes: 6
Registrado: Jue Ago 15, 2013 15:22
por Jristz » Mié Nov 20, 2013 22:16
manualinux escribió:
De hecho según los desarolladores es solo Xfce 4.10, y dentro del desarollo de esta cualquier componente puede tomar cualquier versión (como xfce-terminal 0.6.1 o thunar 1.6.3) y seguir siendo estable.

No es lo mismo 4.10 que 4.10.1, y en este aspecto deberían de mejorar la información que proporcionan de las revisiones del entorno en la página principal del mismo, porque todas las distribuciones y páginas de información sobre linux sí utilizan ese número de versión para hacer referencia a los cambios introducidos en Xfce4. Por cierto, Thunar 1.6.x daba problemas de ejecución con XFce 4.8.x, lo tuve que quitar del manual en su día y volver a la versión anterior. No siempre se cumple lo de la estabilidad supuesta.

http://linux.softpedia.com/get/Desktop- ... 2024.shtml


Es verdad, pero por eso mismo se quito el último digito.
Si había un bug grave en un programa, tenían que esperar a que todos los demas componentes estubiesen listos para la siguiente microversión, lo cual en lugar de ayudar solo retrazaba.
En cambio solo englobando un grupo de programas a una versión mínima (4.10, 4.12) les da la flexibilidad de poder lanzar la versión de ese mismo programa sin tener que esperar a los otros componentes.
Porque si fuera poco, a diferencia de Gnome y KDE, los de Xfce no tiene tanta mano de obra. así que ¿ya vez cuanto han tardado en sacar la verión 4.12? el cambio se inrodujo en 4.10, así que la desinformación brilla.
aunque 'Acerca de' en el panel nos da 4.10 y no 4.10.1.
10 mensajes Página 1 de 1

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado