Instalar Rox-Desktop en Ubuntu 14.04

Menos KDE y GNOME, todos los demás
12 mensajes Página 1 de 1
juan
Miembro
Mensajes: 24
Registrado: Mar Nov 02, 2010 14:10
 
por juan » Mié Ene 27, 2016 14:08
Buenos Días Blue_Light_PDT_01_16
Hace tiempo que instalé Rox-desktop en Debian 6, la idea que tenía era la de actualizar el sistema cambiando Ubuntu 14.04 usando ROX-Desktop como escritorio por defecto. Blue_Light_PDT_01_15
Mi pregunta es: ¿Rox-Desktop es compatible con Ubuntu 14.04 siguiendo el manual http://manualinux.eu/rox.html?
La verdad es que me gusta, con Debian 6 ha funcionado a la perfección, y querría mantenerlo como escritorio por defecto.

Un Saludo Blue_Light_PDT_01_03
manualinux
Administrador
Mensajes: 657
Registrado: Sab Mar 03, 2007 00:43
por manualinux » Mié Ene 27, 2016 14:52
Hola y bienvenido de nuevo al foro, Blue_Light_PDT_01_17

No creo que Ubuntu sea la mejor distribución posible para hacer uso del manual, donde la mayoría de comandos los realizas como usuario root. En Ubuntu el usuario root está desactivado por "seguridad". Con lo que tendrías que "sudar" todos los comandos que aparecen en el manual a realizar como root.

Yo te recomendaría Linux Mint 17 o LMDE 2 con MATE como entorno de escritorio base, que son con diferencia las mejores distribuciones basadas en el mundo Debian que he probado, y son distribuciones normales sin las tonterías de Ubuntu. LMDE 2 está basada en la versión estable de Debian, en estos momentos, la 8.3, más las versiones actualizadas de paquetes como Firefox y otros.

http://www.linuxmint.com/download_lmde.php

http://www.linuxmint.com/download.php

Un cordial saludo.
juan
Miembro
Mensajes: 24
Registrado: Mar Nov 02, 2010 14:10
 
por juan » Mié Ene 27, 2016 18:21
Hola y gracias por la rápida respuesta y por cierto; nunca deje de visitar la Web Blue_Light_PDT_01_12

Con Ubuntu habilito el root #sudo passwd root y después inicio terminal y #su

Pero si crees que va a ser muy complicado lo cambio, tu criterio, para mí, es la verdad absoluta. Blue_Light_PDT_01_10 Blue_Light_PDT_01_10

La historia de elegir Ubuntu es para crear liveCD con systemback y así instalarlo en otros equipos que no están conectados a la RED, el resto lo hago con fog clonándolos.

Esas distros ¿son compatibles con systemback o tienen alguna herramienta para crear LiveCD personalizados? Blue_Light_PDT_01_14
La verdad es que no tengo el tiempo que me gustaría para dedicarle al tema. Además, me he equivocado de lugar pra plantear el tema, debería estar en escritorios ¿Lo puedes cambiar? Blue_Light_PDT_01_33
manualinux
Administrador
Mensajes: 657
Registrado: Sab Mar 03, 2007 00:43
por manualinux » Mié Ene 27, 2016 23:56
Esas distros ¿son compatibles con systemback o tienen alguna herramienta para crear LiveCD personalizados?

http://www.linuxirun.com/foro/index.php?topic=102.0

Pero si lo del root ya lo tienes claro para habilitarlo, elige lo que tú creas más conveniente. En mi modesta opinión, Linux Mint es mejor distrubución que Ubuntu, lo que en su época era Mandrake para los usuarios del mundo RPM.

Además, me he equivocado de lugar pra plantear el tema, debería estar en escritorios ¿Lo puedes cambiar? Blue_Light_PDT_01_33

Pues yo tampoco me había dado cuenta. Por eso no te preocupes, no se penaliza a los usuarios del foro, como somos tantos... Blue_Light_PDT_01_29 Blue_Light_PDT_01_04
juan
Miembro
Mensajes: 24
Registrado: Mar Nov 02, 2010 14:10
 
por juan » Jue Ene 28, 2016 21:00
Buenas noches Blue_Light_PDT_01_02
Pues ya sabiendo que Mint es compatible con systemback, lo de Ubuntu me parece un reto Blue_Light_PDT_01_07 Blue_Light_PDT_01_07 , voy ha intentarlo y comento en este foro mis éxitos Blue_Light_PDT_01_10 y fracasos Blue_Light_PDT_01_23 , y si finalmente es imposible lo intentaré con Mint.
Hasta Pronto
juan
Miembro
Mensajes: 24
Registrado: Mar Nov 02, 2010 14:10
 
por juan » Jue Ene 28, 2016 21:58
Jooo la primera en la frente Blue_Light_PDT_01_38

Al intentar instalar Rox-Clib error, subo el config.log

Imagen
Adjuntos
error-rox-clib.txt.zip
config.los del ROX-clib
(1.96 KiB) Descargado 43 veces
manualinux
Administrador
Mensajes: 657
Registrado: Sab Mar 03, 2007 00:43
por manualinux » Vie Ene 29, 2016 00:08
No es necesario que utilices Clang para compilar el entorno. El error se produce porque la versión de Clang de Ubuntu, no soporta el parámetro -flto, porque no está instalado el plugin de LLVM para aplicar el parámetro. Además el parámetro "-flto" no es aplicable con este paquete concreto.
Optimizaciones adicionales no aplicables
CLANG
LTO
$ export {CFLAGS,CXXFLAGS,LDFLAGS}+=' -flto'

El manual admite la posibilidad de utilizar GCC o Clang, pero siempre partiendo de la base que la versión de Clang utilizada es la del manual ubicado en la web, que es la que incluye todos los componentes y opciones de configuración para poder utilizar los parámetros adicionales.

En el apartado de explicación de los comandos te lo dice muy claro.
export {CC,CXX}=clang : Si vamos a compilar el paquete con Clang, establecemos la correspondiente variable de entorno.

Si vas a utilizar Clang no significa que tengas que utilizarlo por defecto. Puedes utilizar GCC para toda la compilación del manual, y omitir el comando "export {CC,CXX}=clang", allí donde esté indicado.
juan
Miembro
Mensajes: 24
Registrado: Mar Nov 02, 2010 14:10
 
por juan » Jue Feb 04, 2016 22:01
Buenas Blue_Light_PDT_01_06
Bueno después de pararme a leer de nuevo el manual de nuevo, intente instalar Rox-Desktop primero en Ubuntu 14.04, Linux Mint (uno de los enlaces que publicaste) y finalmente Debian 8.2. Todos con el mismo resultado ERROR. Blue_Light_PDT_01_29 Blue_Light_PDT_01_07


Parece ser que no encuentra las librerías gtk+-2.0, cuando intento instalar Rox-Sesion y ahí petay no puedo seguir.
Probé en una versión antigua de Ubuntu, la 10.04, y salio a la primera. Blue_Light_PDT_01_16
¿Es posible que Rox-Desktop no sea compatible con los nuevos sistemas? Blue_Light_PDT_01_34

Te copio parte del proceso (donde da error)
#######################################
checking for unsetenv... yes
checking for getopt_long... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating config.h
config.status: config.h is unchanged
rm -f *.o Makefile.bak gsm-presence-glue.h
gcc -I. -I/home/casa/Descargas/ROX-Session/src -g -O2 -Wall -Wmissing-prototypes `pkg-config --cflags gtk+-2.0 libxml-2.0 dbus-1 dbus-glib-1 gconf-2.0` -c -o main.o /home/casa/Descargas/ROX-Session/src/main.c
Package gconf-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gconf-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gconf-2.0' found
/home/casa/Descargas/ROX-Session/src/main.c:34:22: fatal error: gdk/gdkx.h: No existe el fichero o el directorio
#include <gdk/gdkx.h>
^
compilation terminated.
<builtin>: recipe for target 'main.o' failed
make: *** [main.o] Error 1
Compile failed
Press Return...
############################################################
manualinux
Administrador
Mensajes: 657
Registrado: Sab Mar 03, 2007 00:43
por manualinux » Vie Feb 05, 2016 01:45
Te falta el paquete devel de Gconf.
Código: Seleccionar todo
No package 'gconf-2.0' found

Y sin ese paquete, que lo tienes como dependencia en la sección de ROX-Session, no puedes compilar ROX-Session.

Código: Seleccionar todo
# apt-get install libgconf2-dev

O te lees de forma detenida el manual y las dependencias incluidas en el mismo (dependencias concretas de ROX-Session que mejoré gracias a la información de errores que me proporcionaste en su día con la anterior instalación), o no lograrás instalar ROX Desktop. En lugar de ir probando distribuciones sin saber verdaderamente el problema, deberías de haberme preguntado antes. Porque siempre será mejor que te dé yo la solución, a que te termines desquiciando con la instalación de este entorno de escritorio.

Tengo instalado Debian 8.3 y LMDE 2, entre otras distribuciones. Y con chroot me cuesta muy poco comprobar los errores que se te puedan presentar en la compilación e instalación de ROX Desktop.
juan
Miembro
Mensajes: 24
Registrado: Mar Nov 02, 2010 14:10
 
por juan » Vie Feb 05, 2016 12:51
Buenos Días Blue_Light_PDT_01_02
Pues llevas toda la razón, la verdad es que me desquiciado un poco con esto Blue_Light_PDT_01_29 y lo que me confundió fue; La instalación que me salio a la primera en Ubuntu 10.04 Blue_Light_PDT_01_05 , no se si instalé todas las dependencias a la primera o simplemente suerte. Blue_Light_PDT_01_07

El caso es, que que subsanado este error, si no te importa te consultaré todos los errores que vallan apareciendo. Blue_Light_PDT_01_19

La idea que tengo es; seguir con las tres instalaciones empezando por Debian 8.2 seguido Ubuntu 14.04 y finalmente LMDE 2 con MATE (LinuxMint). Blue_Light_PDT_01_49

Bueno, ahora tengo unos días y me gustaria dedicarle tiempo.
juan
Miembro
Mensajes: 24
Registrado: Mar Nov 02, 2010 14:10
 
por juan » Mié Mar 02, 2016 21:16
Blue_Light_PDT_01_06 Blue_Light_PDT_01_06
Por fin he podido entrar de nuevo en el foro, "Bendito sea el señor" Blue_Light_PDT_01_04 Blue_Light_PDT_01_04
manualinux
Administrador
Mensajes: 657
Registrado: Sab Mar 03, 2007 00:43
por manualinux » Jue Mar 03, 2016 00:05
Me alegra saberlo, pero sigo sin explicarme el porqué no podías entrar. Misterios de internet... Blue_Light_PDT_01_34
12 mensajes Página 1 de 1

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado