E17 Elementary error al configurar

Los olvidados de las grandes distribuciones GNU/Linux
2 mensajes Página 1 de 1
aprendiz12
Miembro
Mensajes: 7
Registrado: Sab Sep 14, 2013 01:01
por aprendiz12 » Lun Sep 15, 2014 00:10
Hola! Blue_Light_PDT_01_05
Lamento tener que postear este problemilla, pero estoy batallando para poder instalar e17 siguiendo el manual de esta pagina, y luego de lograr instalar algunas dependencias manualmente que no vienen en mi sistema ubuntu 12.04 ppc, logre llegar hasta elementary, donde la terminal me da este error:

checking for libv8... configure: error: elev8 requires libv8 >= 3.5.0

Googleando descubri que es una dependencia de ruby etc, y llegue a github donde explican que se puede instalar para ciertas arquitecturas pero no inluye ppc.

https://github.com/cowboyd/libv8
o
https://rubygems.org/gems/libv8

Una solución es intentar escribir en terminal:

sudo gem install libv8 -- --with-system-v8

Cuyo resultado en terminal es el siguiente:

Building native extensions. This could take a while...
Successfully installed libv8-3.16.14.7
1 gem installed
Installing ri documentation for libv8-3.16.14.7...
Installing RDoc documentation for libv8-3.16.14.7...

pero cuando vuelvo a compilar elementary, sigue con el mismo error de no encontrar libv8.

¿Hay algunas manera de poder saltarse esto y seguir compilando las librerias de e17
o algun parametro de configuracion que se pueda aplicar antes del make para poder pasar el error?

PD: Gracias, me divierte intentar optimizar e instalar muchas cosas interesantes de manualinux. Blue_Light_PDT_01_07
manualinux
Administrador
Mensajes: 613
Registrado: Sab Mar 03, 2007 00:43
por manualinux » Lun Sep 15, 2014 01:56
logre llegar hasta elementary, donde la terminal me da este error:
checking for libv8... configure: error: elev8 requires libv8 >= 3.5.0

El error no es del paquete elementary, sino del de elev8. Te lo puedes saltar, y posteriormente borrar el directorio del módulo elev8 en e17/apps/e_modules.
Googleando descubri que es una dependencia de ruby etc, y llegue a github donde explican que se puede instalar para ciertas arquitecturas pero no inluye ppc.

Prueba a buscar esto="libv8 javascript" y te saldrá lo verdaderamente importante, entre otra serie de enlaces:

https://launchpad.net/ubuntu/+source/libv8

https://code.google.com/p/v8/

Y si lo apuramos: "libv8 javascript powerpc ubuntu"

http://packages.ubuntu.com/search?suite ... chon=names

En próximas actualizaciones del manual incluiré esta dependencia o la quitaré, lo más seguro es que la quite. Ya que el módulo elev8 se limita a proporcionar una API para crear módulos en JavaScript (*.js) para Enlightenment.

Un saludo.
2 mensajes Página 1 de 1

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado