Configuración de qingy

Interfaces gráficas de acceso al servidor X
4 mensajes Página 1 de 1
viracocha
Miembro
Mensajes: 8
Registrado: Mar May 22, 2007 00:29
por viracocha » Mié Jun 20, 2007 13:17
Hola. Durante la instalación de qingy, al llegar a qingy-keygen no encuentro este comando. He compilado sobre OpenSSL, no se si tendra algo que ver, de todos modos he continuado adelante y parece que funciona, parece.

Qingy se ejecuta y arranca bien en consola, pero cuando quiero arrancar X no soy capaz.
Los archivos que coloco en /etc/qingy/Xsessions sólo me los lee si su nombre empieza con xinitrc. y si los pongo con este nombre me salen en el menu de qingy pero tras intentar arrancar X vuelve a qingy.
No se si puede interferir alguna configuracion previa de slackware o que puede fallar.
Espero tus sabios consejos y gracias por tu intrès.

Saludos.

 

manualinux
Administrador
Mensajes: 613
Registrado: Sab Mar 03, 2007 00:43
por manualinux » Mié Jun 20, 2007 18:45
Hola. Durante la instalación de qingy, al llegar a qingy-keygen no encuentro este comando. He compilado sobre OpenSSL, no se si tendra algo que ver, de todos modos he continuado adelante y parece que funciona, parece.

Ese comando sólo existe si compilas con el soporte de libgcrypt, con OpenSSL no se usa.
Los archivos que coloco en /etc/qingy/Xsessions sólo me los lee si su nombre empieza con xinitrc. y si los pongo con este nombre me salen en el menu de qingy pero tras intentar arrancar X vuelve a qingy.

En el archivo de configuración de Qingy comprueba si la ruta a este directorio está bien definida,
Código: Seleccionar todo
# Directory containing X sessions
x_sessions = "/etc/qingy/Xsessions/"
# Directory containing text mode sessions

También es fundamental que mires el archivo log de Xorg que se encuentra en /var/log/Xorg.x.log que te indicará que es lo que falla a la hora de iniciar el servidor gráfico. Una manera de probar que el problema no reside en éste es crear un archivo .xsession en tu home, lo editas y añades el entorno gráfico, ejemplo:
Código: Seleccionar todo
exec fvwm

Luego en el menú de Qingy elijes "Your .xsession". Puede también que tengas que añadir la ruta al ejecutable del servidor gráfico y con xinit no funcione, editas el archivo de configuración y descomentas lo relativo a x_server:
Código: Seleccionar todo
# Full path to the X server
x_server = "/usr/X11R6/bin/Xorg"
# Full path to the 'xinit' executable
xinit = "/usr/X11R6/bin/xinit"

Lo que me parece raro es que no te lea los archivos que colocas en /etc/qingy/Xsessions, porque estos tienen que aparecer en el menú siempre y cuando la ruta al directorio la tengas bien configurada. En el caso de fvwm te dejo este ejemplo,
Nombre de Archivo : FVWM
Contenido:
Código: Seleccionar todo
NAME=FVWM
ICON=
EXEC=/usr/local/bin/fvwm
DESC=
SCRIPT:
exec /usr/local/bin/fvwm

O lo puedes poner también de la siguiente forma como un archivo con extensión .desktop

Nombre de Archivo : Fvwm.desktop
Contenido:
Código: Seleccionar todo
[Desktop Entry]
Encoding=UTF-8
Name=Fvwm
Comment=
Exec=fvwm
TryExec=fvwm
Type=Application

El archivo log de Xorg nos tiene que dar pistas que en estos momentos no conocemos, así que espero tus comentarios.

Saludos

 

viracocha
Miembro
Mensajes: 8
Registrado: Mar May 22, 2007 00:29
por viracocha » Vie Jun 22, 2007 12:09
Hola, he seguido tus indicaciones y con ~/.xsessions funciona bien.

El problema que todavia tengo es que solo me lee los archivos cuyo nombre empiezapor xinitrc.

/etc/qingy/Xsession/FVWM --- No me sale en el menu
/etc/qingy/Xsessions/xinitrc.FVWM -- Sale en el menu y con el formato de FVWM que me indicas si arranca el servidor X

Con el formato Fvwm.desktop vuelve a qingy tras intentar arrancar X

En cuanto a los logs de Xorg.1.log no se que buscar , no veo mensajes de error ni cuando me falla el arranque al intentarlo con el formato .Desktop

Se que no te doy información nueva pero no se que mas puede ser relevante en este caso.

Saludos.

 

manualinux
Administrador
Mensajes: 613
Registrado: Sab Mar 03, 2007 00:43
por manualinux » Vie Jun 22, 2007 19:21
Hola, he seguido tus indicaciones y con ~/.xsessions funciona bien.

Por lo tanto, la configuración del servidor gráfico está bien y no es necesario mirar ningún archivo log.
El problema que todavia tengo es que solo me lee los archivos cuyo nombre empiezapor xinitrc.

/etc/qingy/Xsession/FVWM --- No me sale en el menu
/etc/qingy/Xsessions/xinitrc.FVWM -- Sale en el menu y con el formato de FVWM que me indicas si arranca el servidor X

Si nos vamos a la web de Qingy comprobaremos que en Slackware hay que colocar los nombres de los entornos tal y como lo haces tú: xinitrc.FVWM

- Slackware puts its X session scripts in /etc/X11/xinit/ now we honour that, too, following their name pattern "xinitrc.*"

Así que es una cuestión de la distribución y en la próxima actualización del manual se añadirá la información respecto a Slackware.
Con el formato Fvwm.desktop vuelve a qingy tras intentar arrancar X

Aquí puede haber dos motivos, uno, que Slackware no soporte este formato (cosa que dudo), o dos, que no tengas /usr/local/bin en tu PATH (aunque si el .xsession lo has copiado integro y funciona está claro que lo tienes), ya que en el archivo que pongo de ejemplo, no está la ruta completa al binario de FVWM. Comprobar esto es tan fácil cómo abrir una ventana de terminal y ejecutar el comando fvwm --version, si te sale la información significa que FVWM lo tienes en tu PATH, si no sale no lo tienes y por lo tanto tienes dos opciones. Poner la ruta completa al binario en el archivo desktop o la 2ª y más recomendable, añadir el directorio a tu PATH. Normalmente se hace en el archivo .bashrc de tu home pero hay distribuciones que esto no lo pillan. Puedes colocarlo en /etc/profile o en /etc/profile.local (siempre que este último exista) y quedaría así:
Código: Seleccionar todo
export PATH=/usr/local/bin:$PATH

Creo que con este mensaje queda todo aclarado y ya puedes disfrutar del uso de este excelente administrador de sesiones, cualquier duda o problema la planteas en este hilo, también te recuerdo que hagas siempre una copia de seguridad del archivo /etc/qingy/settings porque resulta un engorro tener que volver a editarlo cada vez que instales una nueva versión del programa. En el caso de que el nuevo archivo de configuración contenga nuevas opciones, éstas se copian al anterior en la ubicación correspondiente que es lo que yo hago habitualmente con mi configuración de Qingy.

Saludos.
4 mensajes Página 1 de 1

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado